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Array is an easy to use animation program. If you know the children's toy Lite Brite, 
where you poke colored pegs through a back lit screen, Array is the same idea using 
multiple screens to create animation. 

The simple interface makes it easy for anyone to create at least simple animation.  
You can export your creation as a Flash movie.

This version runs on Mac OS 10.2.8 or better (Jaguar and Panther). Jaguar users 
should run Software Update for recent versions of Mac OSX and Java.

If you use a Mac OS X version lower than 10.2.8, try this earlier version:
http://www.mediumk.com/array/macosx/array-macosx1.2.dmg.sit
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Basic Operation 

Choose from the color palette and paint the frame. Click the 'Next' button to move 
forward, paint the new frame and so on.

When you move to a frame for the first time the contents of the previous frame will 
be copied to it. 

Click the 'Play' tab to play your animation.

To load the animation samples, start Array and use 'File > Load' from the menu.

Selecting Colors



Choose an existing color from the palette. Or double click on a color to create a new 
one. 

When changing color values note that some shades will render better then others. 
Extreme dark or light shades tend to appear flat.

Changing Pen and Background Color

The Current Pen color button is on the left. It is selected by default. Click a color 
from the palette to change the current pen color.

The Current Background color button is on the right. To change the background 
color, select this button and click a color from the palette. Select the Current Pen 
color button when you are ready to draw again.

Picking a Color from the Drawing

Select the Eyedropper button. Click the color from the drawing you want to use for 
the current pen color.

Filling Points with a Different Color

Select the Fill button. Click the color from the drawing you want to fill with the 
current pen color.

Changing Pen Size

Select a Size from the pulldown list. Size 1 is selected by default.

The pen size will be used for Freehand, Strait Line, Shape, and Eraser tools.

Drawing Freehand

Select the Freehand button and draw on the screen. This tool is selected by default.

Drawing a Strait Line



Select the Strait Line button. Click and drag the mouse on the screen. Release to 
render the line.

Drawing a Rectangle Shape

Select the Rectangle shape button. Click and drag the mouse on the screen. Release 
to render the rectangle.

To create a filled rectangle, hold down the APPLE key, then click and drag the mouse 
on the screen. The shape is filled with the current pen color.

Drawing a Oval Shape

Select the Oval shape button. Click and drag the mouse on the screen. Release to 
render the oval.

To create a filled oval, hold down the APPLE key, then click and drag the mouse on 
the screen. The shape is filled with the current pen color.

Adding Text

Select the Text button. A dialog box will appear. 

Enter text. Select the desired font style, size and target layer for the text. 

Generic font styles are available by default.

To make all of your system fonts available, hold down the APPLE key while selecting 
the Text button. They may take some time to load.

Be aware that some fonts on your system will not work properly in Array. You will 
need to experiment to find those which work best.

Erasing Points

Select the Eraser button. Draw over existing points.

To erase the entire screen, hold down the APPLE key while selecting the Eraser 
button.



Shortcut: 
Holding down the 'b' key will temporarily change the pen color to the current 
background color. Releasing it will change it back to the current pen color.

Moving Points

Select the Move button. Click and drag the mouse on the screen, or use the 
keyboard arrow keys to move the drawing on the current frame. 

By default the drawing will move in increments of 1 point. Hold down the APPLE key 
while using the keyboard arrows to move the drawing in increments of 5 points. 

Rotating Points

Click the Rotate button. The current frame will rotate 90 degrees clockwise. The 
center of the screen will be the center point of the rotation.

If you use 'Frame > Rotate 90°' from the menu, you will be prompted to rotate 
points on the current frame, or on every frame of the animation.

Scaling Points

Click the Scale button to increase the size of the drawing. 

Hold down the APPLE key while clicking the Scale button to decrease the size of the 
drawing.

Be aware that scaling may distort a drawing.

Using Layers 

The three numbered buttons control which layer drawing takes place. Layer I is the 
default.

As in other drawing programs, layers function like overlays. You can manipulate 
drawing on one layer without effecting drawing on other layers.

The drawing tools effect the currently selected layer alone. You can 'Add' and 'Copy' 
animation to specific layers.

When the animation is played the higher numbered layer is drawn on top.



Layers can be useful but can also create unexpected results. Experiment with layer 
functionality. Use 'Merge' as needed.

Keep in mind that when you move to a frame for the first time, the contents of the 
previous frame will be copied to it. This only applies to the currently selected layer. 

When saving animation, existing layers will be merged in the resulting file.

Merging Layers

Click the Merge button to combine drawing on multiple layers into a single drawing 
on layer I. Layers II and III are erased.

Flipping Frames Horizontal

From the menu use 'Frame > Flip Horizontal' to flip the drawing horizontal.

You will be prompted to flip the drawing on the current frame, or on all the frames of 
the animation.

Flipping Frames Vertical

From the menu use 'Frame > Flip Vertical' to flip the drawing vertical.

You will be prompted to flip the drawing on the current frame, or on all the frames of 
the animation.

Copying Frames

Click the Copy button, or use 'Frame > Copy Frames' from the menu to open the 
Copy dialog box. The default settings will copy the current frames in sequence to the 
end of the animation. 

You can reverse the 'Copy from range' values to copy the frames in reverse. 

'To frame' is where the first frame of the 'Copy from range' will appear. This can be 
any frame. The copy will be layered over existing drawing.

Optionally you can select a layer for the copy. The default is layer I.

Inserting Frames

Click the Insert Frame button, or use 'Frame > Insert Frames' from the menu to 



insert a blank frame at the current location.

Using the 'Next' button at the end of an animation will also insert a new frame. 

Deleting Frames

Click the Delete button, or use 'Frame > Delete Frames' from the menu to delete 
the frame at the current location. 

Clearing Frames

From the menu use 'Frame > Clear Frame' to clear the drawing on the frame at the 
current location.

You can also clear the screen by holding down the APPLE key while selecting the 
Eraser button.

Moving Between Frames 

Click the Next button to move forward, a new frame is created if necessary. Click the 
Previous button to move backward.

Use the 'Frame' slider to move between existing frames. 

Go to a specified Frame

From the menu use 'Frame > Go to Frame'. In the dialog box enter the frame 
number to go to.

Loading Animation

From from the menu use 'File > Load'. 

When you load a file which was saved with screen settings different from the 
current screen, you will be prompted to adjust the screen. 

You can not load or add animation exported as Flash.

Adding a File to an Existing Animation

From from the menu use 'File > Add'. 

You should first move to the frame where you want the new animation to begin. 
The new animation will be added to the currently selected layer.

When you add a file which was saved with screen settings different from the current 



screen, you will be prompted to adjust the screen.

Loading Animation From the Previous Versions of Array

You can load or add animation from the 1.2 version of Array. Versions earlier than 
1.2 must be loaded and saved first using Array version 1.2.  

Saving Animation

From the menu use 'File > Save'. 

This option saves the animation specifically for this application. You can load and edit 
it again later.

Multiple layers of animation are merged in the resulting file. 

Exporting to a Flash Movie

From the menu use 'File > Export Flash'.

The current design, including the screen size and current play speed will be exported 
as a Flash 5 movie. 

Exporting a Frame to a JPEG File

From the menu use 'File > Export JPEG'.

The current frame will be saved as a JPEG file. 

Exporting the Animation as a JPEG File sequence

From the menu use 'File > Export JPEG Sequence'.

Each frame of the animation will be saved as a JPEG file. This may be useful for 
recreating your animation in other programs.

The frame number will be prefixed to the file name you use in the Save dialog. For 
example, if you use the filename 'cat.jpeg', the resulting file names will be: 

0001_cat.jpeg
0002_cat.jpeg
0003_cat.jpeg
...

Loading a JPEG or GIF Image File

From the menu use 'File > Load Image'. The image will load to the current frame 
and resized to fit the current screen width and height.  

Use the loaded image as is, or as a template to trace over.

Loading images can be tricky. It is important to process the image before loading it 



into Array. Using an image processing program you should probably reduce the 
width and height of the image.

For example, if the current Array screen size has a width of 40 and a height of 30 
(40x30 pixels), and the image you are loading is 640x480 pixels, the resulting 
image would be resized to 40x30 pixels, which may cause significant distortion.

Adjusting the number of colors in the original image is also recommended. If the 
image has a palette of millions of colors, Array will try to process each of the colors 
and the application may potentially run out of memory. GIF or JPEG images with 
minimal colors are recommended.

Playing Animation

Click the Play tab to play your animation. Adjust speed with the 'Speed' slider.

Changing Screen Size 

From the menu use 'Options > Screen Setup'. A dialog box showing the current 
settings will appear. Adjust the 'Screen Width', 'Screen Height' or 'Point Size'. 

The size of any existing animation will not be effected, only the actual screen size. 
Points which fall outside the new screen size are retained. 

The screen in Play mode is effected as well.

The larger the screen, the longer it will take animation to process. Large screen 
animation may not play smoothly. You can save large screen animation using a 
smaller point size if necessary. Exporting as Flash should improve playback.

When you reload a file which was saved with screen settings different then the 
current screen, you will be prompted to adjust the screen.

Setting Preferences

From the menu use 'Array > 'Preferences'. Set the default startup screen size, 
warning dialogs and screen point intensity. 

Preference settings take effect after you restart Array.

Popup menu

To display a popup menu of various options, press the CONTROL key while clicking 
the mouse on the screen in Design mode. Or use the right mouse button if 
available. 

Shortcut keys

Next frame: n 
Previous frame: p



Load a file: Apple key + o
Save a file: Apple key + s

Rotate 90 degrees: Apple key + r
Flip horizontal: Apple key + z
Flip vertical: Apple key + v

Copy frames: Apple key + c
Insert a frame: Apple key + i
Delete a frame: Apple key + d
Clear the current frame: Apple key + l

Preferences: Apple key + ;

Toggle pen to background color: b

Hints and Problems

• Draw or load the samples and experiment with the various functions to get a feel 
for Array.

• The number of frames, the complexity of drawing and the size of the screen all 
have a baring on the time it takes to process the animation. Long, complex 
animation may also use up the available memory for the application. 

• Save your animation frequently. There is no Undo command in Array.

• If your drawing disappears or does not update while in Design mode, try moving to 
another frame and back again to refresh the screen.  

•  If the main window redraws incorrectly after loading a GIF or JPEG image, try 
moving to another frame or Play to refresh the window. You may need to save the 
animation and restart Array. 

• Array works best with 2 or more frames. If for some reason you need to Play only 
one frame, try using 2 identical frames instead.

Please report any problems you find to aaron@mediumk.com.

Information

See 'changes.rtf' for a complete list of changes in version 1.3. 

Array is free but please send me something; your opinion, ideas, an e-card, some 
animation you have created. You can also make a small donation from the web site: 
http://www.mediumk.com/array/macosx.

Array for MacOSX was built from a Java application. The base cross platform 
application is here: http://www.mediumk.com/array/array.html.

Copyright



Array is copyrighted software. The author exclusively owns all copyrights. You may 
use and share this software for non-profit, non-commercial, non-business purposes 
only.

You may not distribute this software in conjunction with any service and/or product. 
You may not modify, translate, reverse engineer, decompile, disassemble or create 
derivative works based on this software.

This software is distributed 'as is'. No warranty of any kind is expressed or implied.

By using this software you agree to these terms.


