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Array is an easy to use animation program. If you know the children's toy Lite Brite, 
where you poke colored pegs through a back lit screen, Array is the same idea using 
multiple screens to create animation. 

The simple interface makes it easy for anyone to create at least simple animation.  
You can export your creation as a Flash file.
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Running Array

Array requires the Java 2 Runtime Environment. If needed you can download the 
Java Runtime from http://java.sun.com/j2se/.

Windows users can double click on the included bat file 'array.bat'. Or double click 
the 'array.jar' file.

General command line usage:
java -jar array.jar array

Basic Operation 

Choose from the color palette and paint the frame. Click the 'Next' button to move 
forward, paint the new frame and so on.

When you move to a frame for the first time the contents of the previous frame will 
be copied to it. 

Click the 'Play' tab to play your animation.

To load the animation from the 'samples' folder, start Array and use 'File > Load' 
from the menu.

Selecting Colors

Choose an existing color from the palette. Or double click on a color to add a new 
one. 



When changing colors note that some shades look better on the screen then others. 
Extreme dark or light shades may appear flat. 

Changing Pen and Background Color

The Current Pen color button on the left selects the pen color. It is selected by 
default. Click a color from the palette to change the pen color.

The Current Background color button on the right selects the background color. To 
change the background color, select the Current Background button and click a color 
from the palette. Select the Current Pen button when you are ready to draw again.

Filling Points with a Different Color

Select the Fill button. Click the color from the drawing you want to fill with the 
current pen color.

Picking a Color From the Drawing

Select the Eyedropper button. Click the color from the drawing you want to use for 
the current pen color.

Selecting the Pen

Select the Pen button to draw. It is selected by default.

Changing Pen Size

Select a Pen Size from the pulldown list. Size 1 is selected by default.

Erasing Points

Drawing with the current background color will erase points.

Shortcut: 
Holding down the 'b' key will temporarily change the pen color to the current 
background color. Releasing it will change it back to the current pen color.

Drawing a Rectangle Shape

Select the Rectangle shape button. Click and drag the mouse on the screen to 
create a rectangular shape. The shape is filled with the current pen color.

Drawing a Oval Shape

Select the Oval shape button. Click and drag the mouse on the screen to create an 
oval shape. The shape is filled with the current pen color.

Moving Points

Click the Move button. Click and drag the mouse on the screen, or use the keyboard 
arrow keys to move the points on the current frame. 



If the Move function does not work using the keyboard arrow keys alone. Try using 
the CONTROL KEY + keyboard arrows.

Rotating Points

Click the Rotate button to rotate the current frame 90 degrees clockwise. The center 
of the screen will be used as the center point of the rotation.

If you use 'Edit > Rotate 90°' from the menu, you will be prompted to rotate points 
on the current frame, or on every frame of the animation.

Flipping Frames Horizontal

From the menu use 'Edit > Flip Horizontal' to flip points horizontal.

You will be prompted to flip the points on the current frame, or on every frame of 
the animation.

Flipping Frames Vertical

From the menu use 'Edit > Flip Vertical' to flip points vertical.

You will be prompted to flip the points on the current frame, or on every frame of 
the animation.

Copying Frames

Click the Copy button, or use 'Edit > Copy Frames' from the menu to open the Copy 
dialog box. The default settings will copy the current frames in sequence to the end 
of the animation. 

You can reverse the 'Copy from range' values to copy the frames in reverse. 

'To frame' is where the first frame of the 'Copy from range' will appear. This can be 
any frame. The copy will be layered over existing drawing.

Optionally you can select a layer for the copy. The default is layer I.

Merging Layers

Click the Merge button to combine drawing on multiple layers into a single drawing 
on layer I. Layers II and III are erased. See 'Using layers' below.

Inserting Frames

Click the Insert Frame button, or use 'Edit > Insert Frames' from the menu to insert 
a blank frame at the current location.

Using the 'Next' button at the end of an animation will also insert a new frame. 
Insert Frame can be used to insert frames in the middle of an animation.

Deleting Frames



Click the Delete button, or use 'Edit > Delete Frames' from the menu to delete the 
frame at the current location. Frame 1 can not be deleted.

Clearing Frames
In Design mode, from the menu use 'Edit > Clear Frame' to clear the frame at the 
current location.

Using Layers 

The three numbered buttons control which layer drawing takes place. Layer I is the 
default.

As in other drawing programs, layers act like overlays. Drawing on one layer will not 
effect the drawing on another. When the animation is played the higher numbered 
layer is drawn on top.

The 'Merge' button combines all three layers into a single drawing on layer I. Layers 
II and III are erased.

Keep in mind that when you move to a frame for the first time, the contents of the 
previous frame will be copied to it. This only applies to the currently selected layer. 
This can be very useful but can also create unexpected results. If you use layers you 
should use 'Merge' frequently.

Previous and Next Frames 

Click the Next button to move forward, a new frame is created if necessary. Click the 
Previous button to move backward.

Use the 'Frame' slider to move between existing frames. 

Loading Animation

In Design mode, from the menu use 'File > Load'. 

When you load a file which was saved with screen settings different then the 
current screen, you will be prompted to adjust the screen. 

You can not load animation exported as Flash.

Adding a File to an Existing Animation

In Design mode, from the menu use 'File > Add'. 

You should first move to the frame where you want the new animation to begin. 
The new animation will be loaded to layer II by default, or layer III if it is selected. 
This allows you to manipulate the new animation separately from any existing 
animation. Use 'Merge' to combine the layers.

When you add a file which was saved with screen settings different then the current 
screen, you will be prompted to adjust the screen.



You can not load animation exported as Flash.

Loading Animation From the Previous Version of Array

Hold down the 'F1' key while selecting 'File > Load' from the menu. You may need 
to adjust the colors of animation loaded from the previous version.

Saving Animation

In Design mode, from the menu use 'File > Save'. 

This option saves the animation specifically for this application. You can load and edit 
it again later.

Multiple layers of animation are merged when saved. 

Exporting to a Flash Movie

In Design mode, from the menu use 'File > Export Flash'.

The current design, including the screen size and roughly the current play speed, will 
be saved as a Flash 5 movie. 

Flash movie play back speed may vary from the speed of the original animation. 
Adjust the 'Speed' slider as needed.

Exporting Frame to a JPEG File

In Design mode, from the menu use 'File > Export JPEG'.

The current frame will be saved as a JPEG graphic file. 

Loading a JPEG or GIF Image File

In Design mode, from the menu use 'File > Load Image'. The image will load to the 
current frame and resized to fit the current screen width and height.  

Loading images can be tricky. It is important to process the image before loading it 
into Array. Using an image processing program you should at least reduce the 
dimensions of the image file.

For example, if the current Array screen size has a width of 40 and a height of 30 
(40x30 pixels), and the image file you are loading is 640x480 pixels, the image will 
be resized to 40x30 pixels, which may cause significant distortion.

You should reduce the original image width and height beforehand to the size of the 
Array screen for best results.

Adjusting the number of colors in the original image is also recommended. If the 
image file you are loading has a palette of millions of colors, Array will try to process 
each of the colors and the application may potentially run out of memory. GIF 
images, or JPEG images with low color settings are recommended.



Playing Animation

Click the Play tab to play your animation. Adjust speed with the 'Speed' slider.

Changing Screen Size 

In Design mode, from the menu use 'Options > Screen Setup'. A dialog box showing 
the current settings will appear. Adjust the 'Screen Width', 'Screen Height' or 'Point 
Size'. 

Any existing animation will be effected. Points which fall outside the new screen size 
are hidden. The screen in Play mode is effected as well.

The larger the screen, the longer it will take animation to process. Large screen 
animation may not play smoothly. You can save large screen animation using a 
smaller point size if necessary. Exporting as Flash should also improve playback.

When you reload a file which was saved with screen settings different then the 
current screen, you will be prompted to adjust the screen.

Screen Point Intensity

From the menu use 'Options > 'Preferences'  to set the screen point intensity. You 
can choose between two intensity settings, 'low' and 'high'. The default is 'high'.

Setting Preferences

From the menu use 'Options > 'Preferences'. Set the default startup screen size, 
warning dialogs and screen point intensity. 

Preference settings take effect after you restart Array.

Shortcut keys

Next frame : n 
Previous frame : p

Load a file : CONTROL key + o
Save a file : CONTROL key + s

Rotate 90 degrees : CONTROL key + r
Flip horizontal : CONTROL key + z
Flip vertical : CONTROL key + v

Copy frames : CONTROL key + c
Insert a frame : CONTROL key + i
Delete a frame : CONTROL key + d
Clear the current frame : CONTROL key + l

Preferences : CONTROL key + ;

Toggle pen to background color : b



Problems and Hints

• The number of frames, the complexity of drawing and the size of the screen all 
have a baring on the time it takes to process the animation. Long, complex 
animation may also use up the available memory for the application. 

• The file selection dialog remains on screen when loading or saving. Wait for the 
hourglass to disappear before continuing.

• Exporting a long animation to Flash may produce a file with varying playback 
speed. 

• If the Move function does not work using the arrow keys alone, try using the 
CONTROL KEY + keyboard arrows. 

• The outline of the Rectangle and Oval shapes occasionally remains on the screen. 
Select another tool, move to another frame or play the animation to remove. The 
outline is not permanent.

• If your drawing appears to disappear in Design mode, try moving to another frame  
and back again to refresh the screen. 

• Dialog boxes may not appear fully on some UNIX versions. Double clicking the 
dialog box title bar, or resizing the dialog box window may help.

• Save your animation frequently. There is no Undo command in Array.

Please email other problems you find to aaron@mediumk.com.

Version 1.2 information

See 'version_log.txt' for complete changes. 

This version of Array is free but please send me something; your opinion, ideas, a 
postcard, some animation you have created.

medium k
260 Banks Street
San Francisco, CA. 94110
aaron@mediumk.com

Copyright
Array is copyrighted software. The author exclusively owns all copyrights. You may 
use and share this software for non-profit, non-commercial, non-business purposes 
only.

You may not distribute this software in conjunction with any service and/or product. 
You may not modify, translate, reverse engineer, decompile, disassemble or create 
derivative works based on this software.

This software is distributed 'as is'. No warranty of any kind is expressed or implied.



By using this software you agree to these terms.


